sidaigle avatar image
sidaigle asked

Cannot install local cluster

Oct 16, 2020 by: sean

I’ve installed the SDK, and I’m not trying to complete the Unity Cube demo.

My first issue was that it would fail at running nomad.exe, during

genvid-bastion install -lmy -b my-bastion

in what looked like a dependency failure. I had a hunch it was caused by the installer not adding the genvid /bin folder to my path.

I added that by hand, and I got to my next issue: it hangs at:

2020-10-16 13:51:37,574:INFO:genvid-bastion:Nomad leader: '', raw_exec driver ready.
Running run on bastion-api

2020-10-16 13:51:37,639:INFO:genvid-bastion:Generating job description for bastion-api

CPU is idle, and it doesn’t return. This is a Windows 10 Pro dev machine with latest updates. Running as Administrator.

Oct 16, 2020 by: Sophie Isabelle Daigle - Technical Publisher & Support

Hi Sean,

Welcome to our Forum!

Thank you for reaching out with your issue, I’m more than happy to assist.

The first thing I’m noticing is the command line that you shared which appears to have a typo. This could potentially cause this issue. Can you verify that you are trying with -lmu and not -lmy as indicated above? We currently don’t have any command associated to the letter y.

Another probable cause could be a firewall or anti-virus. Please verify if this is blocking the process.

Let me know if this resolves things or if the issue persists.


Oct 16, 2020 by: sean

That is a typo from my typing it into the post. I tried it again just to be sure (uninstalling first).

Interestingly, I have a different error now. Looks like it can’t connect to something. I’ve tried this a number of times, and sometimes it hangs, sometimes it spews the socket error. I’ve made sure my firewalls are all off.

Here’s the console output, full output at 1:

2020-10-16 15:43:34,218:INFO:genvid-bastion:Generating job description for bastion-api
2020-10-16 15:43:34,284:ERROR:genvid-bastion:`consul-template` execution failed with exit code '2'
2020-10-16 15:43:34,284:ERROR:genvid-bastion:b'Exception 0xc0000005 0x0 0x7ffee8232fff 0x3480000'
2020-10-16 15:43:34,285:ERROR:genvid-bastion:b'PC=0x3480000'
2020-10-16 15:43:34,285:ERROR:genvid-bastion:b''
2020-10-16 15:43:34,288:ERROR:genvid-bastion:b'syscall.Syscall6(0x7ffee6f456b0, 0x6, 0x2, 0x1, 0x0, 0x0, 0x0, 0x81, 0x0, 0x0, ...)'
2020-10-16 15:43:34,288:ERROR:genvid-bastion:b'\t/usr/local/go/src/runtime/syscall_windows.go:201 +0xfa'
2020-10-16 15:43:34,289:ERROR:genvid-bastion:b'internal/syscall/windows.WSASocket(0x100000002, 0x0, 0x0, 0x8100000000, 0x30, 0xc0001ad340, 0x40c510)'
2020-10-16 15:43:34,289:ERROR:genvid-bastion:b'\t/usr/local/go/src/internal/syscall/windows/zsyscall_windows.go:122 +0xa5'
2020-10-16 15:43:34,289:ERROR:genvid-bastion:b'net.sysSocket(0x2, 0x1, 0x0, 0xe32be0, 0x527cb8, 0xc00016e0c0)'
2020-10-16 15:43:34,289:ERROR:genvid-bastion:b'\t/usr/local/go/src/net/sock_windows.go:20 +0x66'
2020-10-16 15:43:34,290:ERROR:genvid-bastion:b'net.socket(0xaafa40, 0xc00015c780, 0x9ec68a, 0x3, 0x2, 0x1, 0x0, 0x0, 0xab2c40, 0x0, ...)'
2020-10-16 15:43:34,290:ERROR:genvid-bastion:b'\t/usr/local/go/src/net/sock_posix.go:19 +0x61'
2020-10-16 15:43:34,290:ERROR:genvid-bastion:b'net.internetSocket(0xaafa40, 0xc00015c780, 0x9ec68a, 0x3, 0xab2c40, 0x0, 0xab2c40, 0xc00017e300, 0x1, 0x0, ...)'
2020-10-16 15:43:34,291:ERROR:genvid-bastion:b'\t/usr/local/go/src/net/ipsock_posix.go:141 +0x178'
2020-10-16 15:43:34,291:ERROR:genvid-bastion:b'net.(*sysDialer).doDialTCP(0xc00016a280, 0xaafa40, 0xc00015c780, 0x0, 0xc00017e300, 0x94e9e0, 0xe32a60, 0x0)'
2020-10-16 15:43:34,291:ERROR:genvid-bastion:b'\t/usr/local/go/src/net/tcpsock_posix.go:65 +0xc9'
2020-10-16 15:43:34,291:ERROR:genvid-bastion:b'net.(*sysDialer).dialTCP(0xc00016a280, 0xaafa40, 0xc00015c780, 0x0, 0xc00017e300, 0xc00015e180, 0x10, 0x10)'


Oct 19, 2020 by: Francis Provencher - Dev Team Lead

Hi Sean,

We are suspecting an issue where Consul Template is not able to contact Consul.

Possible cause would be that Consul is not reachable due to a firewall issue. You might want to whitelist it to allow access.

Another thing that I see is that you are running the stack as super user, where our entire stack can run as a normal user. I suggest you do a genvid-bastion uninstall in your super user shell/command prompt and try to redo your genvid-bastion install command in a normal user shell/command prompt.

Please let me know how it that helps!

10 |600

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

0 Answers