sidaigle avatar image
sidaigle asked

Tutorial build command fails

Dec 20, 2019 by: stas

Hi, I’m going through the tutorial sample ( 3). Using SDK

I’ve reached the stage where I need to build it using py build but it fails with the following error:

Build started 20/12/2019 23:18:05.
 1>Project "E:\opt\genvid\Genvid Technologies SDK\samples\tutorial\app\Tutorial.sln" on node 1 (Tutorial target(s)).
     Building solution configuration "Release|x64".
 1>Project "E:\opt\genvid\Genvid Technologies SDK\samples\tutorial\app\Tutorial.sln" (1) is building "E:\opt\genvid\Genvid Technologies SDK\samples\tutorial\app\Tutorial.vcxproj" (2) on node 1 (default targets).
 2>E:\opt\genvid\Genvid Technologies SDK\samples\tutorial\app\Tutorial.vcxproj(26,3): error MSB4019: The imported project "E:\Microsoft.Cpp.Default.props" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists
    on disk.
 2>Done Building Project "E:\opt\genvid\Genvid Technologies SDK\samples\tutorial\app\Tutorial.vcxproj" (default targets) -- FAILED.
 1>Done Building Project "E:\opt\genvid\Genvid Technologies SDK\samples\tutorial\app\Tutorial.sln" (Tutorial target(s)) -- FAILED.


   "E:\opt\genvid\Genvid Technologies SDK\samples\tutorial\app\Tutorial.sln" (Tutorial target) (1) ->
   "E:\opt\genvid\Genvid Technologies SDK\samples\tutorial\app\Tutorial.vcxproj" (default target) (2) ->
     E:\opt\genvid\Genvid Technologies SDK\samples\tutorial\app\Tutorial.vcxproj(26,3): error MSB4019: The imported project "E:\Microsoft.Cpp.Default.props" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exis
   ts on disk.

0 Warning(s)
1 Error(s)

Could you please point me to what I might be missing?

Dec 20, 2019 by: Daniel Myers - Tech Writer

So, that seems to be a problem with the installation of Windows Build Tools on your machine. That could be caused by your installed version of Visual Studio. Two questions for you:

  1. What version of Visual Studio are you using? (Depending on the version, it might be a problem with the VCTargetsPath environment variable.)
  2. Are the CPP tools included in your Visual Studio installation? (CPP tools are an option, so they aren’t automatically installed.)

You can solve 1 by setting VCTargetsPath to the correct folder for your version of Visual Studio.
You can solve 2 by going to the Extensions Marketplace in Visual Studio and installing the C/C++ tools.

Let us know if either of those help.


Dec 22, 2019 by: stas

Thanks guys and Dan for getting back on this.

I’m trying to figure out how to set VCTargetsPath (what I’ve found so far on the internet requires windows registry modification, not sure yet it’s the way to go).

Running this command env | grep -i vct in powershell console gives me:
VCTOOLSINSTALLDIR=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023
VCTOOLSREDISTDIR=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Redist\MSVC\14.16.27012

My understanding is that I have CPP tools installed. I guess by Market Store you mean Microsoft Store? When I search for visual studio in the Microsoft Store, it takes me to the visual studio 2019 page.

I’ve got Visual Studio Community 2017 - 15.9.18 installed. Attaching a screen of my VC installer, I’d appreciate a lot if you could guide me to make sure I’ve got the right tools installed!


Dec 22, 2019 by: stas

hi guys, I’ve managed to make some progress though the build still failing. Just briefly where I’m now.

My env looks like:

VCTargetsPath=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets
VCToolsInstallDir=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\
VCToolsRedistDir=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Redist\MSVC\14.16.27012\

When I run py build I get an error as indicated by the py-tutorial-build-failure attachment.



But if I run the msbuild.exe command from the app folder, I get a successful build (manual-msbuild-run)

(sorry, had to remove this attachment due to one photo only limitation)

I’m trying to make py build web and py load work now but any advice or recommendations would be helpful

Dec 22, 2019 by: stas

ok guys, I’ve managed to run the tutorial successfully.

So, the only issue at this moment is that py build game command fails, then I need to go to the app folder and run msbuild manually to do the binary of the game. If there’s something to fix in my environment, please do let me know!



Dec 22, 2019 by: Daniel Myers - Tech Writer

I’m glad to see you’ve gotten that far.

If I recall correctly, it may be that VS Community needs a different version of the MSBuild tools to work for our SDK. I’ll pass your information back to the team and see if we can figure out what’s going on in your environment. If there are other logs/info they can use, I’ll let you know.


cube sampletutorialbuild
10 |600

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

0 Answers